Author Topic: Client troubleshooting  (Read 35389 times)

Misiolap

  • *
  • Posts: 23
    • View Profile
Client troubleshooting
« on: July 07, 2013, 17:46 »
QUICK INSTALATION GUIDE



================================================

This topic is for resolutions of various problems with a FOnline client.

If FOnline.exe isn't working try FOnlineD3D.exe

FOnline.exe requires the card and its drivers to support OpenGL 2.0
FOnlineD3D.exe uses DirectX 9, so should work on wider range of graphics cards.

In general, when client crashes/closes shortly after start open FOnline.log and look for any errors.
When asking for help with a client always post your Operating System version, and your Graphics Card model.

Common errors in FOnline.log:

FOnlineD3D.exe:

Code: [Select]
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND>, legacy compiler errors<E_FAIL
>.

---> Try to install latest microsoft directx end user runtimes <---

FOnline.exe:

Code: [Select]
OpenGL extension 'VERSION_2_0' not supported. Critical.

Your graphics card doesn't support OpenGL 2.0 or your graphics card drivers are too old.
You can try to install latest drivers or if it doesn't help use FOnlineD3D.exe.
« Last Edit: January 10, 2014, 01:27 by Rascal »

Babylon

  • Jr. Member
  • **
  • Posts: 90
  • Never hear bigger bullshit than you say now
    • View Profile
Re: Client troubleshooting
« Reply #1 on: July 07, 2013, 22:40 »
ahh i install NEt. FrameWork 2.0
DirectX 9.0c
And ....
nothing happen
 

falloutdude

  • *
  • Posts: 45
    • View Profile
Re: Client troubleshooting
« Reply #2 on: July 08, 2013, 02:00 »
Hi  I get this error file when i try to run the game. The game opens for 1 second and then closes.

Starting FOnline (version 0436-F7)...
Engine initialization...
Sprite manager initialization...
SpriteManager::Init - Shader 2d contours compilation fail, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>. Used old style contours.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<3D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
Animation3d::StartUp - Fail to create effect, skinning switched to software.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<Interface_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<Primitive_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<Primitive_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<Font_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
GraphicLoader::LoadEffect - Unable to create effect compiler, effect<2D_Default.fx>, errors<ERROR_MOD_NOT_FOUND
>, legacy compiler errors<E_FAIL
>.
Default effects not loaded.
FOnline engine initialization fail.

Misiolap

  • *
  • Posts: 23
    • View Profile
Re: Client troubleshooting
« Reply #3 on: July 08, 2013, 02:09 »
Both of you try to install this and next time read more carefully, it's all written above.

falloutdude

  • *
  • Posts: 45
    • View Profile
Re: Client troubleshooting
« Reply #4 on: July 08, 2013, 03:25 »
Both of you try to install this and next time read more carefully, it's all written above.
Thank you very much I am sorry I did not see what you meant before about downloading directx.  :)

Pataturk

  • Guest
Re: Client troubleshooting
« Reply #5 on: July 09, 2013, 17:09 »
Why dont work with proxy? :(
I need to play with i'm at work! :D


Misiolap

  • *
  • Posts: 23
    • View Profile
Re: Client troubleshooting
« Reply #6 on: July 09, 2013, 20:46 »
Please include report from FOnline.log, and your FOnline.cfg file
« Last Edit: July 09, 2013, 20:49 by Misiolap »

Pataturk

  • Guest
Re: Client troubleshooting
« Reply #7 on: July 12, 2013, 09:13 »
Is it work proxy setting?
I'm tryng to connect at work and i have a proxy... but it does work?
Any suggest?

Misiolap

  • *
  • Posts: 23
    • View Profile
Re: Client troubleshooting
« Reply #8 on: July 12, 2013, 09:41 »
What type of proxy do you have? HTTP/SOCKS4/SOCKS5?

Most HTTP proxies doesn't allow CONNECT to ports other than 21 & 443. Try typing into web browser: http://game.fonline2.com:4000/ and paste what pops out - if error page generated by proxy about dissalowed connection than you can't do much (except maybe proxy chain to some other proxy on port 80/443, but for this you'll need additional software).

Pataturk

  • Guest
Re: Client troubleshooting
« Reply #9 on: July 12, 2013, 10:14 »
Well i have HTTP proxy :(
And http://game.fonline2.com:4000/ dont answer...

You know which additional software can i use? I wanna try... Thanks for answer me ;)

Misiolap

  • *
  • Posts: 23
    • View Profile
Re: Client troubleshooting
« Reply #10 on: July 12, 2013, 11:50 »
If it doesn't answer, and not rejects connection with some message then it's hard to tell weather it should work.

For chain of proxies (2 first results from google):
http://www.proxifier.com/documentation/v3/chain.htm
http://proxychains.sourceforge.net/

Set your work server as first in chain, then some other running on port 80 or 443 or 21. It's not guaranteed to work tho.

Morinvok

  • *
  • Posts: 4
    • View Profile
Re: Client troubleshooting
« Reply #11 on: July 12, 2013, 14:41 »
hello every time i try and run the client it crashes as soon as it pops up  :'(
here is the info from the log file:

Code: [Select]
Starting FOnline (version 0436-F7)...
Engine initialization...
Sprite manager initialization...
SpriteManager::Init - direct3D->GetDeviceCaps( D3DADAPTER_DEFAULT, D3DDEVTYPE_HAL, &deviceCaps ), error<D3DERR_NOTAVAILABLE - Not available>.
FOnline engine initialization fail.

Misiolap

  • *
  • Posts: 23
    • View Profile
Re: Client troubleshooting
« Reply #12 on: July 12, 2013, 17:55 »
What graphics card and what operating system do you use?

Do you have graphics card drivers installed?

Do you have at least DirectX 9.0c installed?

What happens when you try to run FOnline.exe?

Morinvok

  • *
  • Posts: 4
    • View Profile
Re: Client troubleshooting
« Reply #13 on: July 12, 2013, 23:36 »
i was trying to run it on a mac in virtual box, still couldn't get it to work. but i did manage to get it to run natively on mac using wine. i can upload it somewhere if you want, so you can distribute it to mac users as well. i haven't tested everything, but it seems to run fine. :)

skycast

  • Administrator
  • Hero Member
  • *****
  • Posts: 4309
  • Retired
    • View Profile
Re: Client troubleshooting
« Reply #14 on: July 12, 2013, 23:57 »
i was trying to run it on a mac in virtual box, still couldn't get it to work. but i did manage to get it to run natively on mac using wine. i can upload it somewhere if you want, so you can distribute it to mac users as well. i haven't tested everything, but it seems to run fine. :)
What happend when you run it under wine? Can you post log when you running under wine.